Answers from e-Zine!


Welcome back to your source for answers to all your OS/2 questions! Each month we bring you tips, tricks, questions and answers from our readers and contributors. If you've got a question or tip you would like to share with us, send it in!


Q -- Is there a way to back up the appointment book that comes with IBM Works without backing up the entire IBM Works suite or the whole disk?

A -- Yes! You can back up the data from the IBM Works appointment book by switching to the:

X:\bonuspak\ibmworks\data
directory on your Warp 4 system (where X: is the drive IBM Works is installed on), and zipping up, or just copying all the files of the name:
appt.*
This is a crude method but it works. Also, this should work with most of the BonusPak PIM-related applications. For example, you would back up:
todo.*
to save all the Todo list files.
- OS/2 e-Zine! Staff

Q -- I have a problem! I cannot seem to find a way to convince my Netscape Mail client, that I do not live in the Eastern Standard Time (EST) time zone. I can find no clues in the docs, and Netscape's on-line help really only deals with the Windows versions. I do have a hunch however, that the trick might be something with a TZ environment variable, but I have no idea which string to use!

A -- The answer is in your CONFIG.SYS file. Somewhere in it there should be a line that looks like:

SET TZ=EST5EDT
which the Warp 4 install program establishes. Change this to:
SET TZ=XXXnnYYY
where 'XXX' is a character string for your time zone's standard time, 'YYY' is a string for daylight savings time and 'nn' is the number of hours difference from Greenwich Mean Time to your time zone. For example, here in California I use:
SET TZ=pst08pdt
There is also a lot more that can be included in the TZ variable, especially if daylight savings time does not start in your area when all the rest of us do.
- Bob Smith

TIP -- I just came across a solution to something that has bothered me forever and I thought that I would throw it your way.

For a long time now, I have been unable to get NR/2 to save its window positions no matter what I tried. And even though others have the same problem, I have asked repeatedly and no one seemed to know why this is. It is not a setup issue because with identical setups some people had this problem and others did not.

Two days ago I stumbled upon the answer, I believe. I got tired of the slowness associated with dragging windows around in full-drag mode (the standard Warp 4 variety), and turned this feature off. Some time later, I added a newsgroup after finishing reading the news and I resized the main window and saved the position (since the main window was never afflicted by this malady).

Lo and behold, my header window also kept its position! Then I got cocky and tried resizing the article window and it kept its position too! After much mind searching, I realized that the full-window dragging was responsible and after confirming it with another user on the OS/2 setup newsgroup, here you are: a tip

- Carsten Whimster

Q -- Is there a web site or a downloadable list somewhere with all the hardware that works with OS/2?

A -- It may not be complete but a good place to start is the PC systems and devices compatible with OS/2 Warp page maintained by IBM.

- OS/2 e-Zine! Staff

TIP --Misc Hangs At Workplace Shell Start-Up - "Blue Screen Hang"

The system boots normally up to starting the Workplace Shell at which time the system hangs. Sometimes the startup sound will be heard, the background will change to blue or the background bitmap will appear. The cursor turns into a clock followed by nothing.

There appear to be several possible causes for this.

If you run the WarpCenter and Object Desktop and both have the CPU monitor enabled then this can cause a "clash". Try disabling one or the other and see if this gets rid of the problem. Even if you don't have the problem it's probably a waste of system resources to have two apps doing the same thing anyway. I'm not sure if this happens if you are running other CPU monitors (Pulse or shareware) but it is possible.

The registration program that appears in Warp 4 from time to time has a thread running (ARTCHRON.EXE) which might also cause this problem. If the above does not get rid of the problem try eliminating this thread. I have not found what starts this one (there is nothing in CONFIG.SYS or STARTUP.CMD) but one way to get rid of ARTCHRON is to kill the thread (or boot from floppy) and rename the .EXE files to something else. They are in the OS2\ART directory. (Thanks to Kris Kwilas for this one.)

Finally, if the above do not work, try moving the WarpCenter startup from your CONFIG.SYS and putting it in the StartUp folder. Other RUN= statements can also be moved in this way which some users have reported makes the boot more stable.

- Paul Muir

That's it for this month. If you have a tip or question that you don't see covered here, don't forget to send it in!

[Index]  [ Previous] - [Feedback] - [Next ]
[Our Sponsor: House of Technology, Inc. - Your Canadian Source For OS/2 Applications.]


This page is maintained by Falcon Networking. We welcome your suggestions.

Copyright © 1997 - Falcon Networking